Entries

iOSシミュレータにGoogleMapが表示されない。ヴァージョンに注意???

とうとうiPhone用プログラムの開発を始めました。
手始めにGoogleMapでも表示させてみようかと思い、

Xcode ver.3.2.6 をインストールした後に
phonegap-1.1.0 をインストールしました。

ソースは
「PhoneGapでMapKitを使って地図アプリを開発」
http://ascii.jp/elem/000/000/632/632694/

にあるソースを元に必要な箇所を修正しました。

動かしてみたのですが、どうしても地図が表示されない。。。


確認の為に、
作ったindex.htmlを直接Safariで表示させてみたら
ちゃんと動きます。うーん、ますます分からない。。。
iOSシミュレータのヴァージョンのせいなのでしょうか?

ネットでPhoneGapを探した時に、最初にヒットしたのが
Ver.1.1.0 だったので、よく調べずにインストールして
使ってみたのですが、あらためて PhoneGap について調べてみたら、
PhoneGap Fan のサイトでは 0.9.5 を落とすようになっています。
試しに、1.1.0をアンインストールした後に、0.9.5を入れ直した後
再び
http://ascii.jp/elem/000/000/632/632694/
にあるソースを入力してから(もちろん、ソース内のPhoneGapの
ヴァージョンの箇所は直して...) 動かしてみたら、あっけなく動きました。


私のソースの書き方に問題があったのかもしれないけど、Safariでは
表示できたので、おそらく、Xcode ver.3.2.6 と phonegap-1.1.0 の
組み合わせではGoogleMapは表示できないのではないでしょうか。

今日の段階では、PhoneGapのヴァージョンを落とすことによって
GoogleMapが表示された事を確認できただけなので、
iPhoneにおける地図システム開発にかかせない Mapkit については
ノータッチです。MapKitについてはこれから色々と試してみるつもりです。

ある程度いじったら、次は、XCode4とPhotoGap1.1.0の組み合わせでの
動作確認。ひさびさにワクワクします。

そろそろ実機も買いましょうかね。確かに優れたUIです。
iOSシミュレータをいじっただけで欲しくなってしまいました。
しかしこのシミュレータもよくできていますね。感動ものです。

やっと表示されました。GoogleMap
スポンサーサイト
この記事に対してトラックバックを送信する(FC2ブログユーザー)
http://tadpolizemedia.blog118.fc2.com/tb.php/148-663587d3

0件のトラックバック

0件のコメント

コメントの投稿

投稿フォーム
投稿した内容は管理者にだけ閲覧出来ます

Appendix

プロフィール

 二代目松四郎

Author: 二代目松四郎


「カメラと動画(+スチル写真)」
「音響と音楽」
「プログラミング」
を主なテーマに活動しています。
映画館と美術館と音楽ホールと
古い街並みが私の学校。

宮城県仙台市在住。

カテゴリー

ブログ内検索

ブロとも申請フォーム

この人とブロともになる

Counter